详解从angular-cli:1.0.0-beta.28.3升级到@angular/cli:1.0.0

现在Angular CLI在npm下通过@angular/cli来替代angular-cli,并且它只支持Node6.9.0或更高的版本,npm 3或更高的版本。所以在升级angular cli之前,请先升级node和npm。

如果你使用Angular CLI beta.28或更低的版本,你需要先卸载掉 angular-cli包:

npm uninstall -g angular-cli
npm uninstall --save-dev angular-cli

如果你忘记了更新npm,执行上面第一行命令时,会提示你将npn更新到最新版本,npm更新到最新版本后,再执行上面两行命令即可。

将Angular CLI更新到新版本,你必须更新全局包和你项目的本地包。

全局包:

npm uninstall -g @angular/cli
npm cache clean
npm install -g @angular/cli@latest(npm往往会导致安装失败,你可以使用cnpm)

本地项目下的包:

rm -rf node_modules dist # use rmdir on Windows(删除node_modules和dist目录)
npm install --save-dev @angular/cli@latest(npm往往会导致安装失败,你可以使用cnpm)
npm install

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持脚本之家。

您可能感兴趣的文章:

  • Angular项目如何升级至Angular6步骤全纪录
  • Angular5升级RxJS到5.5.3报错:EmptyError: no elements in sequence的解决方法
  • Angular2平滑升级到Angular4的步骤详解
  • angular6 填坑之sdk的方法
  • 利用Angular2的Observables实现交互控制的方法
  • angular 用Observable实现异步调用的方法
  • @angular前端项目代码优化之构建Api Tree的方法
  • 浅谈Angular7 项目开发总结
  • angular中两种表单的区别(响应式和模板驱动表单)
  • Angular(5.2->6.1)升级小结
张贴在3