麒麟系统开发笔记(三):从Qt源码编译安装之编译安装Qt5.12

前言

  上一篇,是使用Qt提供的安装包安装的,有些场景需要使用到从源码编译的Qt,所以本篇如何在银河麒麟系统V4上编译Qt5.12源码。

 

银河麒麟V4版本

  系统版本:
在这里插入图片描述

 

Qt源码下载

  参考博文《获取下载Qt安装包,Qt源码全国网址备忘录(不用注册Qt账户,即可下载各版本Qt安装包和Qt源码包)
  需要哪个版本下哪个版本,笔者经常使用得是Qt5.9和Qt5.12两个大版本,本次下载Qt5.12.7:
&emep; 在这里插入图片描述
  在这里插入图片描述
  由于是自己编译的,我们一般在可以安装Qt版本的时候使用Qt安装版本的QtCreator,但是在本篇文章,我们使用QtCreator也从源码编译,用以补全完全从源码编译搭建环境。
  Qt5.12使用的QtCreator4.8.1,也下载QtCreator4.8.1版本的源码:
  在这里插入图片描述

 

在V4上测试Qt官方安装包

  通过以下测试,是可以直接安装的,正常情况下我们是建议直接安装的,需要自定义或者配置一些模块可能需要涉及到编译源码,那么就可以自行编译qt源码。
  在这里插入图片描述
  在这里插入图片描述
  在这里插入图片描述

 

Qt从源码编译安装

步骤一:下载解压

  在这里插入图片描述

步骤二:配置Qt

  调整当前目录:

cd /home/yang/work/src/qt-everywhere-src-5.12.7 

  然后配置:

./configure -prefix /home/yang/work/qt5.12.7 \ -release \ -opensource \ -platform linux-g++ \ -make libs \ -optimized-qmake \ -pch \ -sqlite \ -qt-libjpeg \ -qt-zlib \ -no-opengl \ -skip qt3d \ -skip qtcanvas3d \ -skip qtpurchasing \ -no-sse2 \ -no-openssl \ -no-cups \ -no-glib \ -no-iconv \ -nomake examples \ -nomake tools \ -skip qtvirtualkeyboard \ -v 

  在这里插入图片描述
  输入y,开始配置:
  在这里插入图片描述
  此时,sqlite是由问题的,不能make,所以修改下配置问及爱你,去掉-sqlite,如下:

./configure -prefix /home/yang/work/qt5.12.7 \ -release \ -opensource \ -platform linux-g++ \ -make libs \ -optimized-qmake \ -pch \ -qt-libjpeg \ -qt-zlib \ -no-opengl \ -skip qt3d \ -skip qtcanvas3d \ -skip qtpurchasing \ -no-sse2 \ -no-openssl \ -no-cups \ -no-glib \ -no-iconv \ -nomake examples \ -nomake tools \ -skip qtvirtualkeyboard \ -v 

  在这里插入图片描述
  在这里插入图片描述

步骤三:编译Qt源码

  根据多年经验,这是个至少长达半小时的过程…

make -j8 

  在这里插入图片描述
  编译完成后,如下图:
   在这里插入图片描述
  再make,多线程编译的时候Qt有时候有前后依赖,挂了一个线程我们也是看不到的(一下就闪过了)。

make 

  如下图:
  在这里插入图片描述

步骤四:安装make install

make install 

  在这里插入图片描述

步骤五:检查Qt使用qmake

  在这里插入图片描述

页面下部广告